
Navigate File Explorer 

When you start File Explorer, the Quick Access view is shown, which contains a 

list of the folders you browse most frequently and the files that you recently 

opened. This list changes as you use different folders, and you can customize it by 

pinning folders and libraries that you’d like to access as quickly as possible.  

On the left side of the File Explorer window, you find the Navigation pane, which 

is a column with several shortcuts. When you open File Explorer, you see these 

shortcuts in the Navigation pane:  

• Quick Access: Shortcuts to the folders you frequently access and the files you 

opened recently.  

• OneDrive: Files and folders that are stored on your OneDrive.  

• This PC: • Your user folders (Desktop, Documents, Downloads, Music, Pictures, 

and Videos)  

• Devices and drives that are available on your computer  

• Network locations: Other computers and devices that are connected to the 

network. If they have shared files and folders, you can access those as well.  

• HomeGroup: Members of your HomeGroup. If they have shared files and folders, 

you can access those, too.  

 

When you click any shortcut in the Navigation pane, its contents are shown on the 

right side of the File Explorer window. To open a file or folder shown on the right, 

double-click it. As soon as you start navigating your Windows computer or device, 

the Back, Forward, Recent Locations, and Up buttons are activated, as well as the 

Address bar.  

Here’s how to use these buttons and the Address bar to browse your computer:  

1. Open File Explorer.  

2. Click OneDrive. The OneDrive folder and its contents are shown.  

3. Click the Back button. You’re taken right back to the Quick Access screen.  

4. Click the Forward button to go to your OneDrive folder again.  

5. Click the Recent Locations button. 

6. In the menu that appears, click Quick Access. You return to the Quick Access 

screen.  

7. Click This PC.  



8. Double-click Documents. As you open a new folder, its shortcut is added in the 

Address bar. If you click on any of the elements in the Address bar, you’re taken to 

them.  

9. In the Address bar, click This PC. File Explorer quickly jumps from the current 

folder to This PC.  

10. Click the Back button to go back to the previous folder.  

11. Close File Explorer. 

Navigate the File Explorer Ribbon 

File Explorer uses a graphical user interface feature called the Ribbon that runs 

across the top of the File Explorer window. The Ribbon comprises several tabs, 

such as File, Home, Share, and View. Depending on what you’re browsing on your 

computer, additional tabs, such as Manage, may be displayed. 

By default, the Ribbon is minimized, and you can see only the names of each tab. 

When you click a tab like Home, you see several buttons and options that are 

organized in logical sections.  

Here’s how to navigate the Ribbon in File Explorer:  

1. Open File Explorer.  

2. Click This PC.  

3. Click Documents. The Documents folder and its contents are shown.  

4. Click the Home tab. This tab includes tools for common operations such as 

Copy, Cut, and Paste, creating new folders and files, moving data, and deleting 

files and folders.  

5. Click the Share tab. This tab includes tools for sharing files and folders with 

others through the network, the HomeGroup, email, or by burning your data to a 

disc.  

6. Click the View tab. This is where you can change how files are displayed in File 

Explorer, and you can also enable or disable different user interface elements.  

7. In the Navigation pane, click This PC. The ribbon is minimized again.  

8. Double-click the C drive, which is usually named Local Disk (C). The Manage 

tab appears on the Ribbon.  

9. Click the Manage tab. Here you find contextual options for managing the C 

drive.  

10. Click File on the Ribbon. A menu appears with options for opening a new File 

Explorer window, starting the Command Prompt and PowerShell, changing folder 

and search options, getting help, and accessing your most frequent places.  



11. In the File menu, click Close to exit File Explorer. 

Maximize or Minimize the Ribbon in File Explorer 

By default, the Ribbon is minimized in File Explorer. If you find it useful and you 

often need to use it, you may want to maximize it all the time. Here’s how to 

maximize and minimize the Ribbon in File Explorer:  

1. Open File Explorer.  

2. Double-click the Home tab on the Ribbon. The File Explorer window changes to 

make room for the maximized Ribbon.  

3. Close File Explorer.  

4. To minimize the Ribbon, open File Explorer again. From now on, the Ribbon is 

maximized each time you open File Explorer.  

5. Click the Share tab to open it. The Share tab is shown on the Ribbon.  

6. Double-click the Share tab. The Ribbon is minimized.  

7. Close File Explorer.  

8. Open File Explorer again. Now the Ribbon is minimized when you open File 

Explorer. File Explorer remembers whether the Ribbon was minimized or 

maximized the last time you closed it and will open it that way the next time you 

open File Explorer. 

Identify Common File Formats in File Explorer 

You can open and view hundreds of file types on your Windows computer or 

device. The most common types of files are documents, music, pictures, videos, 

and executable files. You may also work with specialized files from third-party 

apps, such as PDF files, but usually the types of files you encounter are the 

common ones. What File Explorer shows you depends on what you’re doing on 

your computer. You see either several columns with information or a preview of 

each file. For example, when you open the Downloads folder, you see these 

columns: Name, Date Modified, Type, and Size. 

For folders, the type is always File Folder. But if you’re looking at previews of 

files, you really can’t tell what kind of file you’re looking at, so it’s best to use the 

Details view, where you can get more useful information.  

Here’s how to identify the type of each file shown in File Explorer:  

1. Open File Explorer.  

2. Click Downloads. The Downloads folder and its contents are shown.  



3. Look at the first five to eight files and check their type in the Type column. 

Here are the most common types of files that you may encounter on your Windows 

10 computer:  

• Microsoft Office files: 

• Microsoft Word (.doc and .docx)  

• Microsoft PowerPoint (.ppt and .pptx)  

• Microsoft Excel (.xls and .xlsx)  

• Microsoft Publisher (.pub and .pubx)  

• Microsoft OneNote (.one)  

• Picture files: • JPEG files (.jpg and .jpeg)  

• GIF files (.gif)  

• Bitmap files (.bmp)  

• PNG files (.png)  

• TIFF files (.tif and .tiff)  

• RAW files (.raw)  

• Music files:  

• Windows audio files (.wav)  

• MP3 audio files (.mp3 and .m3u)  

• Windows Media audio files (.asx, .wm, .wma, and .wmx)  

• Free Lossless Audio Codec files (.flac)  

• AAC files (.aac)  

• Video files:  

• Audio Video Interleaved files (.avi)  

• Motion JPEG files (.avi and .mov)  

• Windows Media files (.wm, .wmv, and .asf)  

• Matroska multimedia files (.mkv)  

• Apple QuickTime files (.mov and .qt)  

• MPEG Movie files (.mp4, .mov, .m4v, .mpeg, .mpg, .mpe, .m1v, .mp2, .mpv2, 

.mod, .vob, and .m1v)  

• Other types of popular files:  

• Application files (.exe): Executable files that can run with a double-click  

• Text documents (.txt): Simple text documents without any kind of formatting  

• Compressed (.zip): Archives of other files and folders  

• Portable Document Format files (.pdf): A very popular type of file generally used 

for sharing non-editable documents that need to look the same on all devices, no 



matter what operating system you use• OpenOffice and LibreOffice documents 

(.odt, .ott, .oth, and .odm):  

Depending on the folder that you’re viewing and its content, File Explorer may 

show a column named Type, where you can see the type of each file 

Open a File in File Explorer 

To open a file in File Explorer, browse the locations on your PC, find the file, and 

double-click it. An app, set by default for a file’s type, automatically opens the file. 

To use another app to open a file type, start File Explorer and follow these steps:  

1. Browse to the location of the file that you want to open and select it.  

2. Click the Home tab on the Ribbon. The Home tab is displayed.  

3. In the Open section, click the down-pointing arrow beside the Open button. The 

Open menu is displayed.  

4. In the Open menu, click the app that you want to use to open the file Now the 

app you selected opens your file. 

Move a File or Folder in File Explorer 

You can move one or more files or folders to another location several ways. One 

way is to use the Cut and Paste commands. To do so, open File Explorer and 

follow these steps:  

1. Browse to the file’s or folder’s location and select it by clicking on it.  

2. Click the Home tab on the Ribbon. The Home tab is displayed.  

3. In the Clipboard section, click the Cut button. 

4. Browse to the folder where you want to move that file.  

5. Click the Home tab on the Ribbon. The Home tab is displayed.  

6. Click the Paste button in the Clipboard section. The selected file is now in the 

new folder.  

7. Close File Explorer.  

Instead of using the mouse, you can also use the keyboard. Follow the preceding 

procedure and press Ctrl+X on your keyboard instead of clicking the Cut button, 

and press Ctrl+V instead of clicking Paste. 

Another way to move a file or folder also starts on the Home tab of the Ribbon. 

Click the Move To menu in the Organize section, then click on the name of the 

folder where you want to move the selected item. 

Rename a File or Folder in File Explorer 



You can easily rename files and folders (unless they’re system files that the 

operating system installs in folders, such as Windows and Program Files). Don’t 

fiddle with the files in folders such as Windows and Program Files because you 

could create problems that you might not be able to fix. When it comes to your 

own files (such as documents, pictures, videos, and music), there’s no stopping you 

from renaming files as you prefer.  

To rename a file or folder, open File Explorer and follow these steps:  

1. Browse to the file or folder that you want to rename.  

2. Click the file or folder to select it.  

3. Click the Home tab on the Ribbon. The Home tab is displayed.  

4. In the Organize section, click the Rename button. You can now edit the name of 

the selected item. 

5. Type the new name. 

6. Press Enter or click somewhere else in the File Explorer window. The selected 

file or folder now has the name that you typed.  

7. Close File Explorer. The keyboard shortcut for the Rename command is F2. 

Create a Folder in File Explorer 

You can create as many folders as you want, either directly on a drive on your 

computer or within other folders. Using multiple folders enables you to better 

organize your files, so create as many as you need.  

To create a folder, open File Explorer and follow these steps:  

1. Go to the location where you want to create the folder. It can be a drive on your 

computer or another folder.  

2. Click the Home tab on the Ribbon. The Home tab is displayed.  

3. In the New section, click the New Folder button. A new folder is created with 

the name New Folder.  

4. Type the name that you want for the newly created folder. 

5. Press Enter or click somewhere else in the File Explorer window. The newly 

created folder now has the name that you typed. 

6. Close File Explorer. The keyboard shortcut for the New Folder command is 

Ctrl+Shift+N. Create a File in File Explorer 

You can create files in File Explorer. Actually, you can create them almost 

anywhere, except in system folders such as Windows and Program Files. When 



creating a new file, you first choose its type and then give it a name. To do so, 

open File Explorer and follow these steps:  

1. Go to the location where you want to create the file.  

2. Click the Home tab on the Ribbon. The Home tab is displayed.  

3. In the New section, click the New Item button. A menu appears with several 

types of files. 

4. Click the type that you want, and the file is created.  

5. Type the name that you want for that file. 

6. Press Enter or click somewhere else in the File Explorer window.  

7. Close File Explorer.  

The file that you created is an empty one. To add content to it, you must open it in 

an application that can edit that type of file and add the content that you want. 

Save Your Files 

Many apps work with all kinds of files and allow you to create files on your 

computer that you can use later. For example, you can use the Microsoft Word app 

to create documents and share them with your friends, or you can use Paint to 

create simple drawings and share them with your young family members. To save 

a file, you locate the Save button and click it. Some apps also offer a Save As 

button or menu so that you can choose between multiple file formats before saving 

a file. 

When you save a file, you’re asked to select the folder where you want to save it, 

provide a name for the file, and select the type. To keep things organized, take 

advantage of the user folders and libraries that are available in Windows: Desktop, 

Downloads, Documents, Pictures, Music, and Videos. 

Save your documents in the Documents folder, your pictures in the Pictures folder, 

your downloads in the Downloads folder, and so on. This way, you can easily find 

them when you need them. Another advantage to using these user folders to store 

your files is that Windows 10 automatically indexes them, so you can easily search 

for and find everything that’s stored in them. Searching for files stored in other 

locations takes much longer.  

Here’s an example of how to save files in Windows 10 desktop apps:  

1. Click inside the search bar on the taskbar and type wordpad. A list of search 

results appears.  



2. Click the WordPad search result to create a new document. The Document – 

WordPad window appears.  

3. Type Hello!  

4. Click File. The File menu appears.  

5. In the File menu, click Save. The Save As window appears.  

6. Select the Documents folder in the column on the left.  

7. Type a name for the file; for example, My Document. 

8. Click the Save As Type drop-down list.  

9. Select the file type that you want to use.  

10. Click Save.  

11. Close WordPad. If you go to the Documents folder in File Explorer, you now 

see the file you just created. 

Create a Shortcut to a File or Folder in File Explorer 

You may want to create a shortcut to a file or folder and place it on the Desktop for 

quick access or in some other location that you go to frequently. To create a 

shortcut, open File Explorer and follow these steps:  

1. Locate the file for which you want to create a shortcut.  

2. Right-click that file and, in the menu that appears, select one of these options  

• Click Create Shortcut. This creates a shortcut in the folder where the file is found. 

You can then move the shortcut to another folder.  

• Click Send To; then click Desktop (Create Shortcut). This creates a shortcut to 

the file on the Desktop. 

Shortcuts are references to the files and folders that they point to. When you delete 

a shortcut, the item it points to remains on your computer. On the other hand, if 

you delete or move the file or folder it points to, the shortcut doesn’t work. 

Select Multiple Files or Folders in File Explorer 

When you’re working with files and folders in File Explorer, sometimes you may 

want to select more than one item. For example, you may want to select a group of 

files and delete them or select multiple folders and move them to another folder. 

Here’s the quickest way to select items in File Explorer:  

1. Click the first file or folder that you want to select.  

2. Press and hold the Ctrl key on your keyboard.  

3. With the Ctrl key still pressed, click each file and folder that you want to select. 



4. Release the Ctrl key after you select the items. Each of the selected items is 

highlighted with a blue bar in File Explorer. Now you can apply commands like 

Cut, Copy, or Delete to all selected items. 

Another way to select files or folders in File Explorer is to use the Ribbon. Click 

the Home tab for access to the Selection section.  

Several options in the Selection section of the Home tab let you select and deselect 

groups of files:  

• Invert Selection: Selects the currently unselected files and folders, and deselects 

the currently selected files and folders. Every time you click Invert Selection, the 

selected and deselected files and folders switch.  

• Select All: Selects every file and folder.  

• Select None: Deselects every file and folder. The keyboard shortcut for the Select 

All command is Ctrl+A. 

Delete a File or Folder in File Explorer 

When you no longer need to use a file or folder, you can remove it from your 

computer to free up storage space. To do so, open File Explorer and follow these 

steps:  

1. Locate the file or folder that you want to delete. 

 2. Select that file or folder by clicking on it.  

3. Click the Home tab on the Ribbon. The Home tab is displayed.  

4. In the Organize section, click the Delete button. The selected item is moved to 

the Recycle Bin. 

You can use two keyboard shortcuts for the Delete command: Delete and Ctrl+D. 

Also, you can use Shift+Delete on your keyboard and delete files and folders 

without moving them to the Recycle Bin. When you do that, you can’t restore 

them, because they are no longer stored in the Recycle Bin. 

Restore Deleted Files and Folders 

The files and folders that you delete without using the Shift+Delete keyboard 

shortcut are moved to the Recycle Bin. This is a folder that temporarily stores 

references to the items that you delete from your Windows 10 computer. The items 

in the Recycle Bin aren’t fully deleted, even though they no longer show up in 

their original location. The data from the files and folders that you delete remain on 



your computer’s hard drive until the Recycle Bin is emptied and other files write 

data on top of them in the same location on your hard disk.  

Here’s how to recover deleted files and folders from the Recycle Bin:  

1. Go to the Desktop.  

2. Double-click the Recycle Bin shortcut. You now see a list of deleted files and 

folders that you can recover.  

3. Select the item that you want to restore by clicking on it.  

4. Click the Manage tab on the Ribbon. The Manage tab is displayed. 

5. In the Restore section, click the Restore The Selected Items button. 

6. Close the Recycle Bin window.  

7. Go to the original location of the selected item. The item now appears there. 

Items that are deleted using Shift+Delete aren’t displayed in the Recycle Bin and 

can’t be recovered using the preceding method. You have to use specialized third-

party data recovery desktop apps (such as Recuva) to restore the items. 

View the Properties of a File or Folder 

When you use the default configuration of File Explorer, a lot of information about 

the properties of each file and folder is hidden from view. For example, the file 

extension is hidden by default, and you can’t view when the file or folder was 

created or last accessed. If you want a complete overview of the properties of any 

file or folder, open File Explorer and follow these steps:  

1. Select the file or folder whose properties you want to see.  

2. Click the Home tab on the Ribbon. The Home tab is displayed. 

3. In the Open section, click the Properties button. The Properties window for the 

selected item appears. The available tabs (such as General Details) show 

information about that item. 

4. Close the Properties window when you’re done. You can use the Alt+Enter 

keyboard shortcut instead of the Properties button to open the Properties window 

for an item. You can also right-click a file or folder and click Properties. 

Archive Files and Folders in a ZIP File 

An archive is a file containing one or more files along with their data. You use 

archives to collect multiple files into a single file for easier portability and storage, 

or simply to compress files to use less storage space. Archives are also useful when 

you want to send multiple files to someone by email. Instead of attaching several 

large files, archive them into one file. That file takes less space than sending all the 



files separately, and it’s easier to attach and send by email. The most popular 

format for archiving files is .zip and Windows 10 can automatically work with this 

type of archive without having to install third-party apps.  

To archive several files and folders into a .zip file, open File Explorer and follow 

these steps:  

1. Select the files and folders that you want to archive. 

2. Click the Share tab on the Ribbon. The Share tab is displayed.  

3. In the Send section, click the Zip button. An archive is automatically created in 

the same folder as the files and folders that you selected. You can edit the name of 

the archive. 

4. Type the name that you want for the archive file.  

5. Press Enter or click somewhere else in the File Explorer window. You can now 

use the newly created .zip archive and send it by email or store it where you want 

on your computer. If you want to save space on your hard disk, it’s a good idea to 

delete the files and folders that you placed in an archive, as you can always extract 

them from the archive, using the steps described next. 

View and Extract the Contents of a ZIP File 

When you receive an archive in the .zip format, you can view its contents and 

extract it in File Explorer. Here’s how: 

1. Open File Explorer.  

2. Go to the location of the archive file.  

3. Double-click the file to view its contents.  

4. Click the Extract tab on the Ribbon. The Extract tab is displayed.  

5. Click the Extract All button. A wizard appears asking you to select where to 

extract the files. 

6. Click Browse.  

7. Select where you want to extract the files.  

8. Click Select Folder.  

9. Click Extract. The files are extracted. File Explorer opens the folder that you 

specified, where you can view all the files and folders that were in the archive.  

10. Close File Explorer and the archive you just extracted. The Extract tab on the 

File Explorer Ribbon also gives you options for extracting individual files to 

standard user folders like Documents, Pictures, and Downloads. 

Find Files in File Explorer 



The name of the search bar, which is located in the upper-right corner of the File 

Explorer window, always starts with “Search,” followed by your current location 

in File Explorer. This search bar functions differently from the search bar found on 

the taskbar. First, you can use File Explorer’s search bar only to search for files 

and folders. Also, the search is performed only in your current location. For 

example, if you’re in Quick Access and you type the name of a file, Windows 10 

searches for it only in the locations found in Quick Access. Similarly, if you go to 

the Pictures folder and you type the name of a file, Windows 10 searches for it 

only in the Pictures folder.  

Here’s an example of a search:  

1. Click the This PC shortcut in File Explorer.  

2. Double-click the C drive, usually named Local Disk (C).  

3. In the search bar at the top-right corner of the File Explorer window, type 

notepad.  

4. Press Enter. A progress bar appears at the top of the File Explorer window until 

the search finishes. The results returned are all from the C drive of your computer. 

5. Click the Documents folder in the Quick Access section.  

6. In the search bar, type a different filename, one that’s found in your documents. 

7. Press Enter. The results returned are from the Documents folder, not from other 

locations on your computer. Also, because you’re searching in a location that’s 

indexed by Windows 10, you receive the results much faster than you did in the 

previous search.  

8. Close File Explorer. 

View or Hide Filename Extensions 

By default, File Explorer hides the extensions of each file that it displays, which 

makes it hard to figure out the type of each file. Many experienced users prefer to 

see the extensions of each file so that they are not easily fooled by viruses and 

malware disguising themselves as something else. To view or hide filename 

extensions, open File Explorer and follow these steps:  

1. Go to a folder with lots of files, such as Documents.  

2. Click the View tab on the Ribbon. The View tab is displayed.  

3. In the Show/Hide section, select File Name Extensions. You can now see the file 

extension for each file. 

To hide file extensions, click the View tab and uncheck File Name Extensions. 



View or Hide Hidden Files or Folders 

The Windows 10 operating system, as well as some apps, install folders and files 

that are hidden from File Explorer. They exist and can be used, but they aren’t 

shown to you. Also, you can mark some files as hidden so that others can’t see 

them. Luckily, File Explorer enables you to set whether to view or hide hidden 

items. Just follow these steps:  

1. In File Explorer, click This PC.  

2. Double-click the C drive, usually named Local Disk (C). A list of folders 

appears.  

3. Click the View tab on the Ribbon. The View tab is displayed.  

4. In the Show/Hide section, select Hidden Items. More folders appear on the C 

drive. You should now see a new folder named ProgramData, which wasn’t shown 

earlier. The number of hidden folders that you see depends on your computer. 

To conceal the hidden items, click the View tab and uncheck Hidden Items. 


